Jump to content

Search the Community

Showing results for tags 'scrips'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Proyectos
    • Offtopic
    • Unity Feeds
    • Website
    • Youtube
  • Mesa de ayuda
    • Unity
    • Arte
    • Builds & Dispositivos
    • Otras Especialidades
  • Aportes de la Comunidad
    • Recursos
    • Eventos
  • Bolsa de trabajo & Colaboraciones
    • Ofertas y Demandas

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Especialidad

Found 2 results

  1. Muy buenas a todos. tengo una duda que no logro solucionar, mi problema es que añado una fuerza con addforce y un vector3 a un objeto, pero de esta manera añado la fuerza y la direccion de la fuerza todo con el vector3 y yo quiero poner la dirección por un lado y la fuerza por otro. Sabéis como lo podria hacer? He probado haciendo un normalize () pero no me funciona, me sigue añadiendo también la fuerza y aparte del normalize no se que mas hay para hacer esto. Lo tengo así: DirectionDer = (PosManoDer - PosPelota); DirectionDer.Normalize (); rbPelota.AddForce (DirectionDer * (FuerzaActual * MultiplicaFuerza)); Antes tenia el normalize en la primera linea pero para probar lo quite de la primera linea e hice una nueva solo para aplicar el normalize, pero no cambio nada) La fuerza que se le tiene que aplicar me viene de dos lugares diferentes muchas gracias de antemano . Creo que me he explicado bien: P
  2. Estoy haciendo una APP en Unity, con SQLite. Todo va bien al extraer información de la Base de Datos, el problema es que al cargar las imágenes que saco de la Base de datos, se ve así: Cuando cargo la imagen no me da ningún tipo de error. Ya e comprobado que no me devuelve un arreglo vacío. Incluso me devuelve un mensaje de que todo esta bien. Este es el código con el que extraigo la imagen de la BD: public static Sprite SpriteProducto(int ID) { string conn = "URI=file:" + Application.dataPath + DB; IDbConnection dbconn = (IDbConnection)new SqliteConnection(conn); dbconn.Open(); IDbCommand dbcmd = dbconn.CreateCommand(); dbcmd.CommandText = "SELECT ImagenBLOB FROM TablaProductos WHERE IDTablaProductos = '" + ID + "';"; IDataReader reader = dbcmd.ExecuteReader(); Sprite Respuesta = null; bool n = false; while (reader.Read()) { Texture2D TexturaTemporal = new Texture2D(1, 1, TextureFormat.RGBA32, false); n = TexturaTemporal.LoadImage((byte[])reader["ImagenBLOB"], false); if (n) { Debug.Log("Se cargo la imagen correctamente"); TexturaTemporal.EncodeToJPG(); TexturaTemporal.Apply(); Respuesta = Sprite.Create(TexturaTemporal, new Rect(0, 0, TexturaTemporal.width, TexturaTemporal.height), new Vector2(0.5f, 0.5f)); } else Debug.Log("Ocurrio un error al cargar la imagen"); } reader.Close(); reader = null; dbcmd.Dispose(); dbcmd = null; dbconn.Close(); dbconn = null; return Respuesta; } //Cargamos la miniatura GetComponent<Image>().sprite = ConneciónABaseDeDatos.SpriteProducto(Productos[i]); Alguien me podría decir si estoy cometiendo un error que no veo, o tal vez si tengo que añadir alguna aspecto a la configuración que no noto. Por cierto, estoy usando Unity 2019.3.0a5 Platafroma: Android. Base de Datos Sqlite, con Sqliteadmin
×
×
  • Create New...