Jump to content
Sign in to follow this  
Curly.Wave

Problema cambio de versión 2018 a 2019

Recommended Posts

Hola, me he actualizado de la versión 2018.2 a la 2019.3 y me da errores en ejecución donde antes no me daban y me gustaría saber si puede ser por alguna configuración  de proyec setting.

Yo tengo puesto en scripting backed Mono

Y en api compatibility level NET 4.x

El error que me da es InvalidprogramException: Invalid IL code in gettiempoultimousodeobjetoinventario: IL_0015: ret

La funcion gettiempoultimousodeobjetoinventario es simplemente un case donde devuelv3 un float dependiendo del enumerado de entrada y esto no me fallaba con la versión 2018 y no es solo esto me fallan muchas mas cosas que antes no fallaban, tengo que poner IL2CPP en lugar de Mono?

Gracias de antemano.

Me he dado cuenta que si la función tiene un atributo [Server] da este error, de lo contrario no, por lo tanto el error es cuando uso unet, no es compatible la verdion 2019 con unet?

Share this post


Link to post
Share on other sites
9 hours ago, pioj said:

UNET? Creo que está ya obsoleto, y ahora se usa otra cosa...

 

Así es. Puedes usar Photon o el nuevo de 2019 que se llama Connected Games:

 

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...